RingGo Help centre

Problems when using Internet Explorer 6!

If you are using Internet Explorer version 6 or older then you may encounter numerous issues with the navigation of RingGo. Due to compatibility and the age of the software, we would recommend you update your browser or use an alternative browser such as Mozilla Firefox, Google Chrome, Apple Safari, etc.

Article Id: 36037

Article Last Updated at: 30 Oct 13 10:52

Category: Browser/Technical

Not found what you were looking for?

Why not try our Popular Questions?


Or search by keyword/phrase below.


Getting rid of the warning message about mix of 'secure & unsecure settings'?